Life, Music & The Rest

Wacom configuration issues on Ubuntu 12.04

I just installed the Beta1 of Ubuntu 12.04 in a virtual machine because I’m soooooo curious. Also, I spent about an hour on the internet trying to find out how to configure the buttons on my Wacom Intous3 tablet. And yes, there is a connection between those two seemingly unrelated statements ;-)

Since I just started to work with MyPaint, I’m using the tablet a lot more than I used to since I closed my business. I thought it would be nice to have those buttons (and the strips) available, so googled… and found nothing, at least nothing that worked with the 3.x kernel. Then I noticed that there is a “Wacom tablets” entry in the Gnome control center. Unfortunately, no tablet button configuration options are available:

Click to enlarge

So, out of curiosity I activated the tablet in my virtual machine with Ubuntu 12.04, and behold! there’s an option to “Map Buttons”…


Click to enlarge

Sadly, though…

Click to enlarge

There isn’t anything to configure there, the button list, which I’m assuming should be there, is empty :( No right click options to add them, either, and I couldn’t figure out yet what the problem could be. Whatever it is, I hope this will get fixed by the time 12.04 gets released. It’s going to be really useful.

 

Discuss this article:
6 Responses

6 comments zu “Wacom configuration issues on Ubuntu 12.04”

  1. the d says:

    You say it. After spending months on finding a way to automatically restrict my tablet to left monitor only they now put that little button in there that says “Map to Monitor” … It seems Canonical has finally put some effort to make Ubuntu more usable on multi-monitor systems. I also stumbled over the promising “Map Buttons…”-option with the same result as you. At least you can be quite sure that it’s not your machines’s fault. :)

    Gruß

    D

  2. Tanja Petri says:

    Thanks, that’s good to know… I thought it might have been a problem with running it in the virtual machine, so I decided to reserve my judgement until the final release as I am not about to upgrade my production system to a Beta. But there’s still hope, I guess :)

  3. reya276 says:

    Well I unlike you guys do have config buttons and I can map them, however when trying to put them to use on Gimp 2.8 they do not work. Hopefully a patch will come soon.

    • Tanja Petri says:

      I’m still hoping the problem will be gone after I update my desktop; didn’t get around to do any updating yet.

  4. Tanja Petri says:

    Well… I just upgraded, and it looks like the problem might have been solved. The upgrade is done only now, though, and frankly, I’m too tired to test it. But at least it doesn’t show a blank window anymore.

  5. hmm.. I am now running 13.04 and am not getting the button mapping option.

    I have found a workaround using a script to set xsetwacom, but this seems not to be reliable.

    Do you have any news on this topic? Is stuff just working for you now?

Leave a comment